Support our Sponsors, they keep FADU free:   AG Photographic   Keyphoto   The Imaging Warehouse   Process Supplies   RH Designs   RK Photo   Second-hand Darkroom Supplies   Silverprint Ltd

Notices

Go Back   Film and Darkroom User > Equipment > Darkroom

  ***   Click here for the FADU 2015/2014 Yearbooks   ***

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 4th September 2021, 05:15 PM
ssharp ssharp is offline
Friend
 
Join Date: May 2017
Posts: 28
Default Ilford 500 lamp Issue

Hi All,

This is weird.

Today my left lamp blew on focus startup. No worries, i have 5 so i replaced it.

Well, the new lamp didn't work so i took it out and put another one in.

That didn't work either. I then put that lamp in the right hand position and it didn't work there.

Scratching head i took that lamp out and now i put the original right hand lamp in the left position and it worked, so that lamp worked both sides so i put it back where it started, in the right.

From here i replaced the left lamp 5 (FIVE) times with new lamps and none of them worked.

I know this sounds confusing but i can't have 5 dud in the box lamps can I ?

In a way i almost want to as it takes the heat off the head but i can't find anything wrong with them, no broken coil etc, they just don't work.

Perhaps the only way to find out is to buy more and see what happens with them but i thought i'd check here first.

It's a bit weird. I know the left socket works and i can't figure out 5 dead lamps, unless i got caught out on the auction site.

Any info appreciated.

Simon
Reply With Quote
 
Support our Sponsors, they keep FADU free:   AG Photographic   Keyphoto   The Imaging Warehouse   Process Supplies   RH Designs   RK Photo   Second-hand Darkroom Supplies   Silverprint Ltd

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Enlarger Lamp Colour Temperature. Nat Polton Equipment miscellaneous 12 2nd September 2020 03:27 PM
Opemus colour head 3 - new lamp CambsIan Darkroom 7 26th June 2018 01:36 AM
ILFORD MG500 / Stop Clock 500 - blue lamp not working Tom Kershaw Darkroom 7 14th September 2013 08:54 AM
For swapping/sale V35 Colour modules and 'new style' lamp units alfie Sale or Wanted 0 9th May 2012 06:14 PM
Cheap UV Lamp Barry Alternate printing processes 4 9th November 2010 03:04 PM


All times are GMT. The time now is 11:33 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.