Support our Sponsors, they keep FADU free:   AG Photographic   Keyphoto   The Imaging Warehouse   Process Supplies   RH Designs   RK Photo   Second-hand Darkroom Supplies   Silverprint Ltd

Notices

Go Back   Film and Darkroom User > Site Forums > Introductions

  ***   Click here for the FADU 2015/2014 Yearbooks   ***

Reply
 
Thread Tools Search this Thread Display Modes
  #21  
Old 15th March 2021, 07:35 PM
alexmuir alexmuir is offline
Friend
 
Join Date: Jan 2010
Location: Glasgow, Scotland.
Posts: 2,346
Default

There was some discussion about transformer failure, and possible solutions already on the forum. Perhaps someone who was involved can point to the thread. They sometimes have a fuse in the unit itself, which would be worth checking. The other thing that causes issues with halogen bulbs, if thatís what you have, is deterioration of the bulb holder. The small, ceramic type which hold two pin bulbs can crack over time, causing poor connections. They can be replaced quite easily. Again, there has been some discussion about that issue as well. What model of enlarger do you have?
Alex.


Sent from my iPhone using Tapatalk Pro
Reply With Quote
  #22  
Old 16th March 2021, 04:33 PM
photomi7ch's Avatar
photomi7ch photomi7ch is offline
Friend
 
Join Date: Jan 2009
Location: East Midlands
Posts: 2,425
Default

Welcome Flack
__________________
Mitch

http://photomi7ch.blogspot.com/

If you eliminate the impossible whatever remains no matter how improbable must be the truth.
Reply With Quote
  #23  
Old 16th March 2021, 05:20 PM
Flack Flack is offline
Friend
 
Join Date: Mar 2021
Posts: 15
Default

Well I did some reading and watched a video on the Tube, my transformer is one that needs a load on it to output 12 volts, so when I got a new bulb today, infact I got two, just as well because the first one just went pop as soon as I turned the enlarger on.

Anyway new bulb in and its now working ok. Tomorrow job is light proofing the door, then fully setting out all my gear, then hopefully back in to making some prints. Thanks for the links guys..
Reply With Quote
  #24  
Old 16th March 2021, 05:29 PM
Bob's Avatar
Bob Bob is offline
Administrator
 
Join Date: Aug 2008
Location: London(ish)
Posts: 2,414
Default

Quote:
Originally Posted by Flack View Post
Well I did some reading and watched a video on the Tube, my transformer is one that needs a load on it to output 12 volts, so when I got a new bulb today, infact I got two, just as well because the first one just went pop as soon as I turned the enlarger on.

Anyway new bulb in and its now working ok. Tomorrow job is light proofing the door, then fully setting out all my gear, then hopefully back in to making some prints. Thanks for the links guys..
Good news!

Pity about the first lamp - suggest you order two more . If you have a meter it may be worth checking that the power supply is only supplying the expected 12V and not more.

Have fun!
Reply With Quote
  #25  
Old 16th March 2021, 08:46 PM
Flack Flack is offline
Friend
 
Join Date: Mar 2021
Posts: 15
Default

Quote:
Originally Posted by Bob View Post
Good news!

If you have a meter it may be worth checking that the power supply is only supplying the expected 12V and not more.

Have fun!
Already done that Bob.
Reply With Quote
Reply
Support our Sponsors, they keep FADU free:   AG Photographic   Keyphoto   The Imaging Warehouse   Process Supplies   RH Designs   RK Photo   Second-hand Darkroom Supplies   Silverprint Ltd

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 04:53 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.