Support our Sponsors, they keep FADU free:   AG Photographic   The Imaging Warehouse   Process Supplies   RH Designs   Second-hand Darkroom Supplies  

Notices

Go Back   Film and Darkroom User > Site Forums > News and Announcements

  ***   Click here for the FADU 2015/2014 Yearbooks   ***

Reply
 
Thread Tools Search this Thread Display Modes
  #11  
Old 12th October 2022, 08:26 PM
snusmumriken snusmumriken is offline
Friend
 
Join Date: Oct 2021
Location: UK
Posts: 159
Default

I hope it all works out painlessly, but as I am amazed by what you do, I can be very patient.
__________________
Jonathan

http://www.allmyeye.co.uk
Reply With Quote
  #12  
Old 13th October 2022, 05:36 AM
BuzzNL's Avatar
BuzzNL BuzzNL is offline
Friend
 
Join Date: Jan 2021
Location: The Netherlands
Posts: 311
Default

Quote:
Originally Posted by Bob View Post
I just added a comment to a post, uploaded a photo and added all the details etc and it all worked OK for me. So, not sure why you are having issues. I was using Firefox (not in a Private window, which can add its own complications).

Try editing the image to add the missing details.

That Terry and I were able to post a comment since the upgrade, suggests it may be some config issue on your side (unless others are having the same problem of course).

If still no luck, try deleting all your film-and-darkroom-user.org.uk related cookies and log in and try again. It is possible the system logged you out of the Gallery whist keeping you logged into the forum. The upgrade caused some issues with cookies (this is common) so it is worth deleting them to force it to send new ones the next time you log in.


If anyone else has these issues, please let me know.
Thanks Bob. Just tried editing my photo details and posting a comment again after deleting all cookies, but unfortunately no change.
Also tried using Microsoft Edge (which I've never used before for FADU), which didn't make a difference.

But, I was able to post a comment to Uwe Pilz's photo "Old store in Zeitz" using Chrome. I hadn't tried that before.
Maybe this extra info points in a direction?

If you need me to try or test anything else, just let me know how I can help!
Reply With Quote
  #13  
Old 13th October 2022, 04:14 PM
Bob's Avatar
Bob Bob is offline
Administrator
 
Join Date: Aug 2008
Location: London(ish)
Posts: 2,739
Default

Thanks for trying.

Just adds to the confusion unfortunately! As Edge didn't work either, that rules out a cookie issue as it would not know about FADU cookies, so definitely not that.

I just logged in as a normal member, without my Admin superpowers, and was able to add a photo to an old Exchange Gallery and add a comment to it. All very odd.


We probably need to wait and see if anyone else has the same issue. We don't even use the Ratings option in the gallery, so have even less of an idea why it complained about that...

Cheers, Bob.

Last edited by Bob; 13th October 2022 at 04:19 PM.
Reply With Quote
  #14  
Old 13th October 2022, 05:14 PM
BuzzNL's Avatar
BuzzNL BuzzNL is offline
Friend
 
Join Date: Jan 2021
Location: The Netherlands
Posts: 311
Default

I think I'm onto something Bob. Things go south when I try to enter special characters.

Symbols I've found to be non-working for me so far:
(degree) symbol (ALT + 248 on my keyboard)
– (long dash, alt + 0150). The regular dash (minus on the keyboard) works.

Could it be a charset issue in the database / php config?
It looks like I'm able to use them here but not in the gallery, so then it could possibly be in the gallery table of the database only?

Last edited by BuzzNL; 13th October 2022 at 05:20 PM.
Reply With Quote
  #15  
Old 13th October 2022, 05:26 PM
Bob's Avatar
Bob Bob is offline
Administrator
 
Join Date: Aug 2008
Location: London(ish)
Posts: 2,739
Default

Well spotted. Yes, that would make sense. The gallery is a separate system to the forum; although they do share the same database, the gallery tables may use a different collation - or the special characters may be causing an issue with the upgraded database version where it worked OK before the upgrade.

So, if you do not use the special chars, does it allow you to leave a comment and add the missing details?
Reply With Quote
  #16  
Old 13th October 2022, 05:30 PM
BuzzNL's Avatar
BuzzNL BuzzNL is offline
Friend
 
Join Date: Jan 2021
Location: The Netherlands
Posts: 311
Default

Quote:
Originally Posted by Bob View Post
Well spotted. Yes, that would make sense. The gallery is a separate system to the forum; although they do share the same database, the gallery tables may use a different collation - or the special characters may be causing an issue with the upgraded database version where it worked OK before the upgrade.

So, if you do not use the special chars, does it allow you to leave a comment and add the missing details?
Yes, when I omit those characters everything goes well. I just added the missing info to my photos by replacing the special characters with something plain ASCII and that seemed to work.
Posting a reply under my own photos also works when I omit special characters.
Reply With Quote
  #17  
Old 13th October 2022, 06:46 PM
Bob's Avatar
Bob Bob is offline
Administrator
 
Join Date: Aug 2008
Location: London(ish)
Posts: 2,739
Default

Good news! .

I'll keep this in mind as we sort through the other issues (only one is really important, but it's a doozy...) - there may be a similar cause.

Cheers, Bob.
Reply With Quote
  #18  
Old 13th October 2022, 06:57 PM
BuzzNL's Avatar
BuzzNL BuzzNL is offline
Friend
 
Join Date: Jan 2021
Location: The Netherlands
Posts: 311
Default

Thanks again Bob, and definitely good news and perfectly workable as-is, it's just a bit more easy debugging when you understand what's going on!
Good luck with all the little annoyances that pop up during such an upgrade.
Reply With Quote
  #19  
Old 13th October 2022, 07:59 PM
BuzzNL's Avatar
BuzzNL BuzzNL is offline
Friend
 
Join Date: Jan 2021
Location: The Netherlands
Posts: 311
Default

Dug a little further, I apologize for keeping rambling on about this one thing...
But possibly I found another lead and perhaps it is of use in other issues as well.
Just had a look at my earlier gallery posts, for example in the september print exchange gallery, there the degree symbol is still visible in my older post.
(I always write the developer temperature with that symbol in the photo details).

To me that could indicate a PHP / SQL / encoding issue during input towards the database rather than a database / table charset issue, as apparently the table is capabele of storing such characters and the gallery displays them properly as well, it just seems to not store new strings containing such symbols for some reason.
But here on the forum they do get encoded and stored correctly since the upgrade.
There could very well be a difference in encoding/parsing the data to the database between forum and gallery.
Again, I'm not trying to force any priority on this issue at all, but maybe the above finding is also useful in solving other issues!
Reply With Quote
  #20  
Old 13th October 2022, 09:47 PM
Bob's Avatar
Bob Bob is offline
Administrator
 
Join Date: Aug 2008
Location: London(ish)
Posts: 2,739
Default

No problem - all hints and suggestions welcome!

The gallery code was not touched during the upgrade, only the forum PHP files were upgraded, but changes to the version of PHP and MariaDB may well have caused a compatibility issue with the existing PHP code for the gallery (the gallery code is now very obsolete and no longer supported - or indeed, available).
Reply With Quote
Reply
Support our Sponsors, they keep FADU free:   AG Photographic   The Imaging Warehouse   Process Supplies   RH Designs   Second-hand Darkroom Supplies  

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fadu means different things to different people - So what does fadu mean to you? MartyNL Photography in general 1 26th August 2022 05:19 PM
FADU Down! Barry News and Announcements 25 25th September 2018 07:23 PM
Hello Fadu MartyNL Introductions 9 4th September 2010 09:06 PM
Hello FADU Peter Fitz Introductions 13 3rd September 2010 04:55 PM
Hello FADU ErinW Introductions 11 6th April 2010 01:50 PM


All times are GMT. The time now is 02:53 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.